Location: Bowdoin / Polaris / Guides / Firefox Browser

Polaris

Firefox Browser

To take full advantage of the features available in Polaris, we recommend using the latest version of Firefox. Polaris will work with other web browsers (e.g., Safari, Chrome, and Internet Explorer 9 or higher) but its full functionality is best achieved with Firefox.

If you already use Firefox follow the directions for updating Firefox to version 23.0.1

If you do not use Firefox or are having trouble upgrading, follow the directions below to install Firefox 23.0.1.

Not sure what version of Firefox you are using? Follow the steps below.

Macintosh:

  1. Open Firefox
  2. Click on the Firefox menu located in the status bar next to the Apple icon. Select “About Firefox in the drop down menu.
  3. The version you are currently using will be displayed in a pop up box. The first number that appears (example: 5,6,7,8 or 9) indicates the version of the web browser installed on your computer (you can also click the “check for updates” button to see if you are running the latest version.


Windows:

  1. Open Firefox.
  2. Click the “Help” menu.
  3. Select “About Firefox” in the drop down menu.
  4. Next to “version”, the first number that appears (example: 5,6,7,8 or 9) indicates the version of the web browser installed on your computer.


Linux:

  1. Open Firefox.
  2. Click the “Help” menu.
  3. Select “About Firefox” in the drop down menu.
  4. The version you are currently using will be displayed in a pop up box, under the word "Firefox."